Boogie
Poštový klient · macOS · iOS · iPadOS · watchOS
01.
V App Store · 2026
Natívny poštový klient JMAP.

Vaša pošta. Na vašom serveri.

Live captureNo waiting
35,037 messages — usable from the first secondthe rest streams in behind you · real capture

Boogie je natívny e-mailový a kalendárový JMAP klient pre Mac, iPhone, iPad a Apple Watch — s plnohodnotnou aplikáciou pre hodinky, v ktorej napíšete aj nový e-mail, so vstavanými kalendármi Fastmail a Stalwart a podporou 40+ jazykov. Pošta zostáva na vašom serveri — my ju čítať nemôžeme. Žiadne analytické SDK. Voliteľný Boogie Push vás upozorní na novú poštu, aj keď je aplikácia zatvorená.

Jazyky
041
Platformy
04
Špecifikácia
RFC 8620
Testov
611
TOUR
— Prehliadka
Boogie 1.4.6
2 min · so zvukom

Dve minúty s Boogie.

1.4.6Mac · iPhone · iPad — 2:12
UI
— The interface
Native macOS
Mail · Calendar

Natívne rozhranie.

Boogie Mail — Q3 Budget Review HTML letter in the reading pane
01Mail
Boogie Calendar — week view with Design Review selected
02Calendar
NEW
— What's new
Shipped recently
Pozrite si úplný zoznam zmien →

Novinky

+
Vyhľadávanie podľa poľa.
Zúžte akékoľvek vyhľadávanie pomocou from:, to:, subject: alebo body: — v pošte vo vašom zariadení aj na vašom serveri naraz.
— 1.4.6
+
Kalendáre Fastmailu.
Prihláste sa cez Fastmail a vaše kalendáre prídu s ním — vytvárajte udalosti, pozývajte ľudí a odpovedajte na pozvánky.
— 1.4.6
+
Pošta, aj keď je aplikácia zavretá.
S voliteľným doplnkom Boogie Push vám iPhone a iPad dajú vedieť o novej pošte, aj keď je Boogie úplne ukončený. Vaša pošta zostáva súkromná: nemôžeme ju čítať.
— 1.4.5
+
Priečinky, ktoré si vyberiete.
Predvolene prichádzajú oznámenia z Doručenej pošty. Zapnite ľubovoľný ďalší priečinok, jeden po druhom.
— 1.4.6
02.
— Section 2
Behaviour
Six entries

Šesť inžinierskych rozhodnutí.

2.1
Push, nie dopytovanie.
JMAP stavia na push. Žiadny 60-sekundový cyklus dopytovania IMAP. Správy prichádzajú trvalým kanálom vo chvíli, keď ich má server. CPU zostáva studené.
— RFC 8620
§ 7
2.2
Dávkové volania.
Jediná požiadavka JSON môže niesť desiatky operácií naprieč správami, schránkami, identitami a kalendármi. Sieť je tichá. Klient je rýchly.
— RFC 8620
§ 3.6
2.3
8620 od začiatku do konca.
RFC 8620 a RFC 8621 implementované v plnom rozsahu, vrátane častí, ktoré väčšina klientov ticho vynecháva. Prečítali sme špecifikáciu od prvej po poslednú stranu.
— RFC 8620
+ 8621
2.4
Natívny, doslova.
SwiftUI na každej platforme Apple. WatchKit na zápästí. Žiadny Electron, žiadna vrstva Catalyst, žiadne vstavané Chromium.
— Four
targets
2.5
Chladné súkromie.
Žiadne analytické SDK, žiadne knižnice tretích strán odosielajúce dáta, žiadny obsah schránky opúšťajúci zariadenie. zásady ochrany osobných údajov sú zámerne krátke.
— Rev 5
11 sections
2.6
Každé písmo.
RTL nie je len prepínač. Indické zhlukovanie nie je dodatočný nápad. 40+ jazykov a každý vysádzaný tak, ako to jeho čitatelia očakávajú.
— 40+
locales
03.
— Section 3
Protocol
IETF · 2019

Protokol v tabuľke.

Vlastnosť
— IMAP · since 1986
— JMAP · since 2019
Prenos
Plain TCP · line-based
HTTPS · JSON · multiplexed
Aktualizácie
Dopytovanie každých n sekúnd
Odosielané trvalým kanálom
Tvar požiadavky
Jedna operácia na príkaz
Desiatky operácií na volanie
Špecifikácia
RFC 3501 (revised 2003)
RFC 8620 + RFC 8621
Servery
Univerzálny · každá éra
Stalwart · Fastmail · Apache James
04.
— Section 4
Implementations
Four targets

Štyri natívne ciele.

01.
macOS
App Store
— Dodávaný
02.
iOS
App Store
— Dodávaný
03.
iPadOS
univerzálny balík
— Dodávaný
04.
watchOS
BoogieWatch
— Dodávaný
05.
— Section 5
Localisation
40 locales

Štyridsať jazykov.

06.
— Section 6
Questions
Nine entries

Časté otázky.

6.1
Čo je JMAP?
JMAP (JSON Meta Application Protocol) je moderný, otvorený e-mailový štandard definovaný v RFC 8620, ktorý nahrádza zastaraný protokol IMAP. Využíva efektívny JSON cez HTTPS, podporuje push v reálnom čase a spravuje e-mail aj kalendáre cez jedno zjednotené API.
— RFC 8620
6.2
Čo je Stalwart Mail Server?
Stalwart Mail Server je open-source, vlastne hostovaný e-mailový server napísaný v Rust, ktorý implementuje jednu z najkompletnejších dostupných špecifikácií JMAP, pokrývajúcu e-mail, kalendáre a kontakty.
— Rust
server
6.3
S ktorými servermi Boogie funguje?
Boogie funguje s akýmkoľvek serverom, ktorý implementuje štandard JMAP, vrátane vlastne hostovaného Stalwart Mail Server a Fastmail. Podpora sa rozširuje, keď ďalší poskytovatelia nasadzujú JMAP. Vyskúšať Fastmail — 10 % zľava na prvý rok →
— JMAP
standard
6.4
Ako sa Boogie porovnáva s Apple Mail?
Apple Mail používa IMAP a SMTP, protokoly z 80. a 90. rokov 20. storočia. Boogie používa JMAP, čím vám dáva push v reálnom čase, integrovanú synchronizáciu kalendára a architektúru vytvorenú pre moderné a vlastne hostované servery.
— vs IMAP
6.5
Podporuje Apple Mail JMAP?
Nie. Apple Mail používa iba IMAP a SMTP – nemá žiadnu podporu JMAP a Apple žiadnu neoznámil. Boogie je natívny klient JMAP pre macOS, iOS, iPadOS a watchOS, takže je to spôsob, ako používať schránku JMAP s pushom v reálnom čase a integrovanými kalendármi na zariadeniach Apple.
— Apple
Mail
6.6
Na akých platformách beží Boogie?
Boogie je dodávaný na macOS, iOS, iPadOS a watchOS z jednej multiplatformovej kódovej základne Swift. Aplikácia watchOS píše e-maily natívne cez JMAP priamo zo zápästia, bez odovzdania na telefón.
— Four
targets
6.7
Podporuje Boogie offline e-mail?
Áno. Boogie udržiava lokálnu databázu vášho e-mailu a zaraďuje odchádzajúce zmeny do fronty, keď ste offline, a synchronizuje sa s vaším JMAP serverom hneď po obnovení pripojenia.
— Offline
queue
6.8
Aké sú systémové požiadavky Boogie?
macOS 15 alebo novší na Apple Silicon (M1 alebo novší), iOS 18 a iPadOS 18 alebo novší a watchOS 11 alebo novší. Všetky zostavy sa dodávajú cez App Store, s podpisom kódu a notarizované.
— App Store
6.9
Prečo Boogie používa JMAP namiesto IMAP?
IMAP bol navrhnutý v roku 1986 a nahromadil desaťročia rozšírení. JMAP je bezstavový protokol založený na JSON, ktorý spája viacero operácií do jednej požiadavky, doručuje aktualizácie v reálnom čase a spravuje kalendáre spolu s e-mailom v jednom API.
— Since
2019
— Section 7 · Action

Stiahnuť Boogie.

14-dňová skúšobná verzia · bez platobnej karty
KTP Digital Pty Ltd · ABN 85 648 755 980 · Patent pending (AU 2026904881)
Melbourne, Austrália · 2026